Blank screen on Ipad; unable to login to image PLATFORM or Forum on Ipad


I haven’t been able to access tomnod campaigns or the forum on my ipad for a few days now. I can see the forum but when I try to log on it brings me to a blank, black screen (same screen when trying to access campaigns).

I am able to access things on my desktop at work, but I use tomnod on my Ipad at home…


@HappyMapper @tomnod @tomnodjon
I’m also not able to access the forums and/or the campaign from
my tablet (Samsung Galaxy Tab S2 (Android)).

AKE235 - (Forum Moderator)


I can’t see anything on my Acer laptop either. Just a black screen when I go to

Strangely I have been able to click on the link in the email and see this page.


Have you been required yet to update / change your password on your typically-used device? If yes, the issue may be connected to alternate devices.

If you have not yet changed your PW, log out of your typically-used device (first). Try logging in to see if you are required to do the PW. IF the screen seems non-responsive to your PW pick, choose “I forgot” and get the email sent to you. Try to log in with the NEW PW via the emailed link. THEN try logging in with all your other-used devices.

Post back here if non-PC devices still won’t let you in. Give as much detail as possible, like if you did new PW; what kind of device and OS, etc.


Cagey, I was able to use my Galaxy Tab, while I was in the hospital and had no issues. Now, I followed the steps to reset and renew password on the tablet after I was discharged and still had no issues. Now, nothing but a blank screen. - bob


Hello Cageycat!

Thanks for your help, but unfortunately I don’t even have the option to log out because the whole screen is blank. There is literally nothing to see or click on.


I am unable to log out on my Ipad because the screen is blank. I just tried logging off and back in on my PC desktop and Tomnod was unable to connect to the server to log me in (I was able to log off). I also tried the “forgot my Password” option and again received the cannot connect to server message.


I just checked my email and there was a link to reset my password, even though I was just told tomnod can not connect to server. I clicked on the link and was able to reset my password. I tried logging in again on my desktop and the tomnod server can not connect.


I have just cleared the cache, browsing, cookies in Chrome on my Ipad. This does not work. I have done the same in Explorer. In Explorer, a black screen does not even appear when I go to and, the app just crashes.In Chrome, I went to and in both regular mode and incognito mode and got the blank black screen.

My Ipad is Generation 3, Model MC707LL/A, circa March 2012. I am running IOS 8.1.2. I can not upgrade to latest Chrome version because it requires IOS 9. I have not updated my IPad to IOS 9 because of the problems encountered post-upgrade on IPad 3rd gen (according to various message boards, articles on the subject). I also am unable to update to IOS 8.4 because that is no longer an option at Apple.

So I am also running the latest version of Safari usable on IOS 8 but probably not the latest version available.

Maybe the problem is that I can no longer run tomnod on IOS 8 :sob:

This would be disappointing as I use my IPad for tomnod when I am in bed winding down to sleep!


ut oh I guess we better call —> @Jon_Saints (play Ghostbusters music in background…) and @HappyMapper since they don’t want people to be having black screens!

If you want “just the facts, ma’m”, read up the thread.
If you don’t mind quirkiness, read downward…

Problem - Black Screen Monsters have taken away Tomnod! Black Hole Encroaching!

Playground of preference - non-PC Devices

New Login Effects - None, at least directly?

Server - Yes!
Put Plug A back into Plug B to re-establish connection.
Then raise all shields against the Black Hole. Hurry!

Effects - Nodder Withdrawal.

Rated - Moderate withdrawal symptoms

CDC recommendations - Reestablish server connection. Use Cool Cloth on Forehead until Black Hole shields are fully raised. Rocky Road Ice Cream supposedly gives some temporary relief.

Nodders should post back here when they can get back in so Tomnnod will know if the fixes worked. If not… ~~~scream, loudly ~~~ :thumbsup:

Quirky :cat2:


Hey Cat.,
In re: Rocky Road Ice Cream supposedly gives some temporary relief. - So does a Double shot of Scotch on The Rocks! :yum::dizzy_face:


ahem… I prefer warm milk please (especially so I can sleep through tomorrow).


I also have the black screen , however, it is a work computer(it used to work), it maybe a security issue, although it’s not telling me it can’t connect… I’m using a Windows 7 Pro 64 bit machine, before the blackout(pun intended), I did periodically get “long script” error, in which the machine would appear to freeze, and a dialogue box would appear saying the it was running a long script and would I like to stop it.


Hello again

I’ve only just seen this post of yours and it says it’s happening on non-PC devices, but that’s not true. My laptop is a PC and it’s got black screen. I can see no maps and I am not even able to see the initial welcome page. I haven’t been able to look at your site, bar the discussion forum, for many weeks now.

This is my most desperate hour. Help me, Cageycat. You’re my only hope.


2 shots of 100 proof vodka, shot of 150 proof Puerto Rican rum, shot of Southern Comfort. repeat as needed. maybe a little seven up to fill up the glass. Luckily, I am experiencing no problems re: Tomnod signin. Pass the floor, please.


@Sophie Let me introduce you to @Jon_Saints He is all things “savior” at Tomnod, along with @HappyMapper

If only I could turn the lights back on for people who cannot get into the platform.


Everyone who is having black screens when visiting

could you try these links and tell us if you get in on any of them?

Tell if you used a PC or other device.

Edit: These URLs work on an old Systemax laptop with new login established a couple weeks ago. OS WinXPro However, reports of jet black non-loading platform so far include both PC and hand-held devices on much newer OS’s…

Sorry folks. I hoped if I gave you some working urls we could bypass the issue temporarily. Guess not. :frowning: If it is any consolation, there are no newer campaigns loaded, yet so you’re only missing out on the building poly campaign.

Free catnip tea and cute kitties to scritch in the Cageycat Catnip Lounge thread. :wink:


I clicked on all and all are blank screens. Ipad gen 3, running iOS 8


I AM ABLE TO USE tomnod campaign and forum on a IPad mini generation 2 running IOS 10, BUT NOT on my older IPad generation 3 running IOS 8 (not an option to upgrade to 10).


Cat, I tried entering the site and the three Congo campaign panes using 3 devices. My laptop, tablet and cellphone with various results. The Cellphone is a Samsung S6 Edge+.
Could enter the forum with no issues. The campaign site and the three panes were black. The Tablet is a Samsung Galaxy Tab S2. Could enter the forum with no issues also. Again, the campaign site and the three panes were black. Kind of odd, but recall doing campaign work, while I was recovering from surgery using the tablet. As far as the cellphone is concerned, I really had no need to use it for Tomnod, except to read my emails. I tried to connect to the site and to test the panes listed, but nothing but black screens. Had no issues with the laptop. I can provide all of the technical data on the devices upon request.

  • bob of The Mod Squad