Error - Your connection is not private


#1

From the morning only, I have been facing problems accessing Tomnod from my laptop. I tried everything but I am still the error.

It goes like - Your connection is not private

Attackers might be trying to steal your information from www.example.com (for example, passwords, messages, bank information or credit cards).

NET::ER_CERT_COMMON_NAME_INVALID

Can anyone suggest me anything. I posted this thread from my smartphone only.


#2

Hi… First suggestion would be to provide a bit more information… Computer type, OS and version, Browser (s) in use (available) for a start… oh and connection type… Ethernet, Private wireless, or public Wifi site…

This sounds similar to something we experienced a year or so back… when there was a problem of some sort with Certificates… some browsers were not recognizing the current ones… thus did not implement https mode.
That can also happen with some browsers where there is external data being loaded… i think some ad sites can do that… some don’t but that’s because the browser site pre empts them for their ad site which is of course recognized… we’ll see, I’m not an expert by any means, but those that are could use that information at a minimum… meanwhile look to see if the https// etc. is there… make sure almost every thing is shut off… ie don’t leave a mail program running for the test… and watch to see what tries to run on it’s own…
I seem to remember it was related to warnings from either Google or Firefox being a bit over enthusiastic…
and perhaps a bit of old Certificates lagging behind… sometimes wiping cookies can remove that problem…
Just make changes one at a time in that regard, always helps to know which one you run into for future reference… I’ll see if I can find the other thread.


#3

Not sure if this is the best OLD thread on this, but is related I believe…

Security Certificate - no cause for alarm

Make sure to read down a few messages… only 10 there. Might help…

Will tag @cageycat who started that stuff… maybe something new.


#4

Hi @Alex_Bach

YouTube has several videos about fixing that error. Since I don’t know your browser, I’ll post a link to all the videos:

https://www.youtube.com/results?search_query=NET%3A%3AER_CERT_COMMON_NAME_INVALID


#5

Hi @Alex_Bach, While you didn’t mention which browser you are using, that particular error message seems to be more common in Chrome. I use Firefox myself, and when I connect to the Hurricane Maria campaign, instead of a green lock icon, I have a black lock with a “hazard” icon (white exclamation mark inside a amber triangle). When I click on it, it tells me that some content is not being transmitted securely, i.e.: images. This was one of the technical problems with this campaign in particular. Everything else is secure.
Chrome may give a different error message than what Firefox does, but I am not familiar with Chrome. Here is a website that has a lot of solutions to many computer/Internet problems. The first link is to the problem you have and the second link is to their “solutions” pages.
How to fix error msg: NET::ER_CERT_COMMON_NAME_INVALID
https://www.XtremeRain.com/solutions/

As Doug4 suggested, your OS and Browser info is most helpful in these types of matters.


#6

@Jim7 @Doug4 Thanks for reaching out. I didn’t realize you guys would help me with that much support.

Also, I am extremely sorry for not providing complete details. I am using Asus Vivobook S14 running on Windows 10. And Yes, I have been facing the error in Google Chrome.

Now that you’ve added so many resources, I’ll be sure to go through each of them.


#7

You’re quite welcome, Alex. We may not be the techs one would find in other support forums, but many of us have had these problems before and sometimes had to figure the solutions out ourselves. Suggestions are always welcome. :wink:

Here’s another link you should definitely check out. It explains what Google did to cause this error (in Chrome v. 58 and above, and gives a work around. Note that this work around requires making a registry entry, so always back up your registry BEFORE making any changes. That way, should something unforeseen happen, you can always go back to the registry before you made the change.
NET::ERR_CERT_COMMON_NAME_INVALID when using HTTPS inspection TECH240507 October 18th, 2018 https://www.symantec.com/docs/TECH240507


#8

Glad that you guys were able to fix my error. I also found a relevant link for fixing Your Connection is Not Private in Chrome. I am leaving it here for anyone who might face the same issue in future.

Thanks for your help <3


#9

You are welcome! I think all of us had some variant of that at some point… or other…


#10

Hi Alex, I don’t think there’s much to discuss about here because everyone seemed to have given enough resources for you. As @Doug4 suggested, you should first go through this post - Security Certificate - no cause for alarm

Now that you understand the problem better, maybe you can solve it too. Try using the fixes from the following resources.

As @cageycat suggested, you should try the video, and maybe using method 3 & 4 from here to fix Your Connection is not Private Error.