Island Mapping Hangs Browsers


i almost got through all the squares in my search area last night… over 5000 squares and 300 marks.
but now, if i try to go into that same search, it hangs… from the bizarre ad screen that tells you what tomnod is…
not even the mapping… then the second panel over that that says stuff… and not even the mapping…

once i got the mapping up in explorer (i generally use firefox), and it had speckled and did not show the squares i searched
as if half of them reverted back randomly to not searched (despite some having some island marks in them)

and yes… i did clean out my cache…


Hey there, sorry you’re experiencing the slowness! Let’s try and figure this out: have you tried refreshing your browser and clearing your cache?

If you’ve tried both of those and it’s still going slow, try logging out and contributing as a guest (guest work will be added to your profile each time you log back in).

Meanwhile, we’ll take a closer look at why it’s behaving slowly. @tomnodryan


Just remember if working while not logged in, you must log in before you close the browser. :smile: The log in records the work you just did. Then you can exit the browser.