[Solved] Bug: Swaziland Verification - it now steps back "down" if you zoomed


Something important changed on how the images are working.

Verification loads at Z1… (It’s too hard to see tiny buildings at Z1!) I put it to Z+2 or Z+3. Great, I can see the building and the poly.

I click my choice… the image stays…nothing happens. (confusing) Click choice again…again…

  • Then I realized, it is stepping itself back down automatically to Z1 or Z0 before it will accept the choice.

This is going to cause confusion if everyone doesn’t know that the image is reducing back down. It could end up with folks clicking the choice multiple times trying to get the image to “go” and one of those clicks could get put on the next loading image before the person realizes it.

Worse, it means we are clicking double the amount now (going up and now go down too).

These buildings and huts are SO small; can’t we load the images automatically at Z+2 or Z+3 @tomnodcollin @tomnodjon ? Please?? I explained in another post why it can be hard on some folks. And could you make it stop having to “step down” before it accepts the choice?

Good example of stepping: http://www.tomnod.com/campaign/swaziland_polycheck_2015_01/polygon/72918
Thank you.

P.S. Is California campaign for swimming pools, parking lots, and solar panels completed now?


I tried this link and experienced no automatic change in zoom level when clicking on my vote.

However, before voting, when I first loaded the page, the map and polygon were all-black – nothing visible but the interface. Changing the size of the browser window made it pop on. This is the same glitch reported here in the Bridge Validation campaign.


Try this one with the poly partly over /the building partly under the tree. Zoom in. Turn off poly and turn it back on. Then select a choice. It steps back down for me:

Try this for both large huts in the center:


^ I tried it, and yep – after zooming in to level 2 and clicking on the choice, the next map that loads is back at level 1.


No, not the next map. The map that does the stepping back down is the same map where I was doing the marking… it steps “back down” to 1 before accepting the choice.


Ah, gotcha. No, it won’t do that for me. Just the “black until you zoom in” glitch when first loading the page. Strange!


Sorry @cageycat - that link works fine for me…! I zoomed right in to +3 then clicked my choice, and it just accepted it and went right on to the next map…
Have you rebooted your browser (or computer)? I guess you’d probably have already tried that… (but with my techie “helpdesk” hat on, sometimes you do have to ask that question…!)


yep, I do comp tricks.

I don’t know why it was being persnickety. I quit last night and haven’t retried it today.


Once again, an image steps. I set it to Z3 to see it. Click my choice. The image is smaller; e.g. I think it loaded a new image. Not so! It “steps back down” on the zoom level to Z2-- click choice AGAIN… zooms back down 1 more to Z1. THEN one more time I click my choice, and it finally accepts and moves on.

What is being recorded is unknown… Are my first 2 clicks plus my last click being recorded? They do increase my counter. Does the image I need to mark just once then get vetted 3x ? Or is it changing only my counter, but only registering one vote on the server? If it is recording 2 or 3 votes from me, that could really mess up crowdsourcing data, not to mention I’m getting 3 numerical points on the counter for every building when this stepping occurs.

It isn’t occuring on every image. I had a long stretch where nothing went wrong. But once stepping starts, it continues on every image. Wish @tomnodjon could check for this buggy problem.


Hey @cageycat,

I’m not seeing this issue either. What browser and OS are you using? I’ll try it there.


Hi @tomnodcollin This message was posted 12 days ago. I posted later that I found a workaround:

Workaround: I set the browser’s zoom at 150% to 175% with images left at the loading level of Z1. I never need to zoom in on Tomnod’s tool.

Result: The “stepping” from Z3 back to Z1 stopped with setting the browser’s zoom. Since it isn’t stepping back downward from Z3 and I’m not clicking the choice more than once now, it also isn’t adding to my counts. It zips to the next bldg now without zooming issues after my first choice.

I normally use Chrome Incognito ver. 44.0.2403.125 m.