What was wrong today with the servers?


Tomnod would accept login but Forum would not.

Tomnod kept auto redirecting from www.tomnod.com to www3.tomnod.com Neither URL would load to a campaign.

Did anyone else have this?

I ran anti-virus checkers, etc. Nothing wrong on this side.


We are in the process of changing over to a brand new API. We did a “soft” move this week where we moved some Nodders to the new API so we could monitor bugs etc on a smaller scale. We experienced some issues this afternoon with the redirect, but things should be better now!

Please let us know if you continue to experience any issues!


LOL My getting in is the problem @HappyMapper

Knock knock!
Lemme in.

Btw, I sent you a snail mail. Hope it arrives quickly.


Thanks! I’ll keep an eye out :eyes:


I now have disappearing markers. I have placed the mark on the mosque on the lower left side and before I can move up to ditch the cross hairs it goes POOF!!! So I put it there again and just waited and yeppers sure enough it consumed that marker too. Tried one more time just in case it was a case of nervous server and left it in it’s invisible state. :coffee:


@Pastor_Ruth - yes, I had the same problem in the Erbil part of the campaign, but when I did the other cities it worked well again.


TAGS THAT GO POOF! That sounds funny. LOL! :smile: I have had some tags and poligons go POOF too.


YES! I have been trying to get my nodder fix for darn near 24 hours. - I WANT MY OLD TOMNOD BACK!

I tried every trick in the book to login. (Wait, there is no book! my bad). That being said, I’ve tried everything I could think of in my 40 some years in messing with computers and software. I spent 5 years as software user and debugger for AOL. I know first hand that rolling out a major software upgrade can be a very challenging feat, to say the least!


Hey all, we’ve been testing a complete overhaul of our back end over the past couple days and have been fixing issues as we find them. At least for now we believe we’ve tracked down the major bugs, but definitely let us know if you run into more problems.

As far as the disappearing tags, that was just an issue of a dependent server request timing out instead of returning properly, which then caused the tag API to error out. That should be fixed now.

@AKE235 - We fixed the various login bugs we found, are you still having issues?


@tomnodryan – No issues, just a note that a “quirk” still exists on the forum login: after entering name and password it first logs me into the Swaziland: Map Buildings Campaign opening page. It remains visible for one to three seconds before the forum loads.

It’s not an issue for me because I know to wait for the forum to load, but it might confuse new members who could end up clicking the “Start Searching” button that is prominently visible on the Swaziland page.


@tomnodryan I got in for a little bit, but got kicked out last night.

I have not been able to get in.
So I used the URL posted about dinosaurs.
Loaded to black.
Super slow till I thought it was a black image.
Changed Zoom up and down.
About 1/4 inch of the bottom of a square loaded.
Squares began popping in.
Noticed I was at zero “scores”.
Started looking around - fewer than 6 or so images.
Then the frames stalled, and the API pulled an “Amy Winehouse” e.g. “Back to Black”.

" I tread a troubled track
My odds are stacked
I’ll go back to black"

Like @AKE235 I want Tomnod back! Missing the little fixes I get at any time of day in between my other tasks.

@HappyMapper What’s an API?

@Bob1 If logging into Forum first, New or Old Users won’t get a response to “Start Searching” because it acts like a unlinked link in that specific circumstance. It then rolls to Forum. New Users likely won’t go to Forum first anyway, because they won’t be typing in the Forum URL.


@Bob1 Yeah, that’s just a side effect of what we had to do in order to get Tomnod logins working for this forum. It’ll likely stay that for way for now.

@cageycat More details would be great. We fixed some things this morning around 11 AM MST, have you been having issues since then? By not able to get in do you mean the site won’t load or you can’t log in?


API - Application Programming Interface


Still having problems with fading or disappearing markers. Continuing since last night… I attempted this morning and thought maybe propagation? Tried again at 4:25 EST with W7 64 using Chrome. Here is one of the maps that just fades away. http://www3.tomnod.com/campaign/dghg_sitediscovery_2015_02/map/48ox8gy1mv

Will give it a rest until tomorrow… maybe the dust has to settle down and recover from all those pointy sticks :grimacing:

You just are not going to get rid of us that easy ya know!!! :coffee:



Busy, so have not tried it since before 6am Eastern time today.

By not loading, I mean (over the last 24 hours, in different attempts):

First it was redirecting to www3 and staying stuck, never loaded.

Then, it redirected but only loaded the front screen; could not login.

Then, it let me login to the campaign, but not the Forum. But the campaign loaded black and would not come up with my name, stats, or images. I could only scroll through the new front page.

Then, I used a Nodder’s posted URL. That session wouldn’t let me continue.

Just now, I tried loading www.tomnod.com in Chrome Incognito

I counted to 25 before www3.tomnod.com loaded. Sign in OK. STUCK at What Is Tomnod-- X on Tomnod screen is unresponsive. Delay long enough I got Chrome’s message for unresponsive website–do you want to wait. I let that box sit without clicking-- within seconds it resolved itself and it flipped rapidly from the Instruction screen to the image (e.g. the delay there is gone. Normally I can read the screen then use the X to go to images). It finally loads 2 frames of images, one above the main screen, but the frames are half-sized (not full screen) and at Z1 is too tiny to see. Moving mouse on screen is very “touchy”-- do a short swipe and the image becomes uncontrollable; it shoots across and flips it to a new image, new building. (If I leave the map sit I get a unresponsive do you want to wait message, it resolves, then, it rapidly loads more frames, one by one or by twos, until the whole map is there .) Stepping down bug still there. Put browser at 175%… picked “Needs Editing” but stuck there at javascript://(nothing else) so it never moves off that image: URL is a random one. F5 to reload, repeat what I reported so far.

So I’m stuck on URL random with an empty javascript message at the bottom left corner of Windows screen.

I would say:

  1. Server drag with the redirect to www3
  2. Login OK now
  3. The time delays set are not in sync for user actions and server response (load campaign screen, move mouse to Tomnod’s X, is “off” on the timing. X not responsive to click. Then suddenly the server responds. ALSO, no action required if I wait long enough-- it does the X by itself without clicking it, which is annoying if you’re reading the instructions.)
  4. Very long delays in loading one frame/image. Two vertically placed boxes / images load together.
  5. Frames [boxes] and images aren’t loading right. (a) Tries to load global map but can’t. (b) loads very reduced size on frames/boxes (not same size as we had). © Loads nothing…then all of them, all at once. Confusion “does the user want one image?–oh heck, I’ll give the user the whole map”.
  6. Server TOO responsive to User Mouse swipes once the map loads. A swipe can send me to a different city LOL.
  7. Stuck at random after selecting vote, like we’ve had before. Non-responsive.
  8. The empty javascript// ______ “url” – as if the server doesn’t know what it’s supposed to do. We had this problem before too.

Keep tweaking. I’ll try again tonight.


Thank you, @AKE235 - Shoot, says post must be 20 characters…so… How are you today? :smile:


Great, thanks for the detailed info, it helps a lot with troubleshooting. We’ll be keeping an eye on things, but let us know if the problems continue tomorrow.


I’m doing well, Thank You. I read your post and instantly flashed back to my adventure of opening the door to Nodderland. a land where anything can appear or disappear, a land where you can be transported to anywhere in a server Johnny second! Sounds kind of familiar to a story I once read long ago.


LOL, @tomnodryan I’ll just go back to learning how to do nested lists, :::sniffle:::: I have a huge page to write. See what happens when Tomnod has issues so I can’t go hide in there? I’m sent to my own html “hell”. Shucks, gee golly wiz.

Have a good day, while I figure out my ul and li coding. Sigh.


Server keeps loading areas that I have already searched (tags are visible). I had the problem with disappearing tags for a time and figured out that it you are trying to tag something out of the square you are supposed to be searching it will not accept the tag - solution: move up or down to the next block and the tag will stick. I’m just working the religious tags so that may not apply to other nodders. I’m loading the www3 version without problems unless I try to zoom back - in which case it takes forever to accomplish the action but will eventually do it (don’t kill the page in Chrome).